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Supported Music Formats: 
Fireball E2, DVDM, SE, MX, AVX models & Fireball-PC supported music 
formats:  

- MP3 (Up to 320Kbps CBR. VBR is also supported) 
- FLAC* 
- WMA (192Kbps CBR / 215Kbps VBR. Lossless is not supported) 
- AAC** (Lossless is not supported) 

 
* SE-80 does not support FLAC. 
** Requires Fireball software version 4.2 or later. Fireball-PC requires version 
4.2.3.6 or later 
(v4.2 update subscribe http://www.escient.com/support/updates.html) 
*** Fireball E models (E-40/120) require the following E2 software update in 
order to stream music files using Fireball-PC and your PC/Mac. 
http://www.escient.com/eupdate/ 
 

What is a tag? 
Most digitally encoded file formats allow information particular to each file to 
be embedded within the file itself. This information is referred to as metadata 
and is included within what is known as a tag. A tag can include a multitude of 
information of which can contain but is not limited to artist, album, track, year, 
genre, and cover art. 
 

Metadata Requirements: 
In order for the Fireball to properly display all artist/album/track/cover art 
metadata once the music file(s) have been imported, the file must first contain 
a proper tag embedded within the music file itself. Different types of tags are 
used depending on the file format being imported. The following list describes 
the corresponding tag which each music format requires. 
 

·  MP3 (ID3 Version 1.0, 1.1, 2.2, and 2.3) 
·  FLAC (Ogg Vorbis) 
·  WMA (Microsoft Standardized) 
·  AAC (Apple Standardized) 

 
In order to for your music files to import properly all tracks must include an 
artist name, album name, track name, track #, and genre (group). Tracks 
which are to remain as a single album once imported need to have an 
identical artist name, album name, genre, along with a unique track # (i.e. 1, 2, 
3, etc.) per track. 



FireBall – Supported Digital Music Formats & Tagging Requirements 
2/18/2010 

 

6640 Intech Blvd.   Indianapolis, IN 46278   317.616.6789 phone   317.616.6790 fax   www.escient.com 
 

 

Purchased Music Files & DRM 
DRM, which stands for Digital Rights Management, is a technology used 
mainly in restricting the playback of most legally purchased music through 
online music stores. DRM was created on behalf of the music industry as a 
whole to allow content owners to determine and control who and how users 
can view content such as media files on the Internet. However, there are both 
advantages and disadvantages to DRM. Unfortunately, due to DRM, 
compatibility between music playback hardware and software is severely 
limited. Any company wishing to produce hardware/software compatible with 
music files that include DRM technology must directly support each type of 
DRM technology and is up to the company in which the music files are 
distributed on whether to license this technology out to 3rd party companies.  
 

Apple FairPlay DRM & iTunes Plus 
Music files purchased through the iTunes online music service must be 
purchased in an unprotected format in order to transfer the files to the FireBall. 
Apple calls their DRM-free (unprotected) content “iTunes Plus”. If you’ve 
previously purchased content in a protected format, Apple will allow you re-
purchase this content in iTunes Plus format for a few additional cents per 
track. Each track’s file extension will end in .m4a if it’s in a compatible, 
unprotected AAC format. However, if the track ends in a .m4p extension 
(protected) or is in AAC lossless format then it is not compatible. 
 

Online Music Services 
The following online music services offer DRM-free music distribution and are 
compatible with most 3rd party digital music hardware and software. 

·  www.amazon.com/mp3 
·  www.itunes.com (iTunes Plus format) 
·  www.rhapsody.com (To Go subscription) 
·  www.emusic.com (30 day free trial) 
·  www.amiestreet.com 

 
Additional online music services such as the examples included below use 
some form of DRM to restrict playback of purchased online music and do not 
offer 100% compatibility with 3rd party software and hardware. 

·  Yahoo! Music 
·  Napster 
·  MusicMatch 
·  MSN Music 

Recommended Tagging Software 
The chart below lists many recommended compatible and supported tagging 
applications along with each supported file format. 
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Mp3tag  is our current recommended PC tag editor and handles all supported 
music file formats. You may even use Mp3tag to embed cover art within your 
music files. Mp3tag can be downloaded from the following location. 
http://www.mp3tag.de/en/. 
 
 
 

Software Supported File 
Formats 

Website 

Windows Media 
Player 

MP3 / WMA http://www.microsoft.com/windows/wind
owsmedia/default.mspx 

Apple iTunes MP3 / WMA/ AAC http://www.apple.com/itunes/ 
Mp3tag v2.35 MP3 / FLAC / WMA 

/AAC 
http://www.mp3tag.de/en/ 

The GodFather MP3 / FLAC http://users.otenet.gr/~jtcliper/tgf/ 
Taggin’ MP3 MP3 http://www.lazorsoftware.com/lazorsoft/t

agginmp3.php 
Tag & Rename MP3 / FLAC / WMA 

/AAC 
http://www.softpointer.com/tr.htm 

 

Cover Art Requirements & Online Resources 
Fireball has requirements on cover art resolution and file size of all cover art 
that is embedded through the systems web interface as well as imported via 
the Fireball’s CIFS interface. These requirements are as follows: 
 
Maximum Resolution: under 500x500 pixels 
File Size:  

Hard drive based models: under 50KB 
SE-D1 & DVDM-100: under 25KB 

 
Included below are a few website that will help in searching for music cover 
art which that can then be embedded within your music files using a tag editor. 
 
Amazon.com  http://www.amazon.com 
AMG  http://www.allmusic.com 
FindMyCover.com  http://www.findmycover.com 
AlbumArt.org  http://www.albumart.org 
 
Note: Fireball itself also has the ability to search for all missing cover art after 
importing of your digital music files. You will find this under Options>Get Info> 
Get Music Info>Unknown Covers. 
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Music Titles with Multiple Artists (Various Artists ) 
Compilation albums generally include multiple artists such as soundtracks 
and greatest hits. The metadata within these albums may need to be edited 
before being imported from your PC to the Fireball depending on the software 
originally used to identify and rip the album to your PC. In order for all tracks 
within a single album with multiple artists to show up as a single album once 
imported onto the Fireball, you will need to format each track’s tag to include 
identical artist and album information. An example of this has been included 
below. 
 
Improperly Formated  
Track Artist Album Track Title 

1 Janet Now That’s What I Call 
Music, Volume 1 

Together Again 

2 Backstreet 
Boys 

Now That’s What I Call 
Music, Volume 1 

As Long As You Love 
Me 

3 Fastball Now That’s What I Call 
Music, Volume 1 

The Way 

 
Properly Formated 
Track  Artist Album Track Title 
1 Various 

Artists 
Now That’s What I Call 
Music, Volume 1 

Janet – Together Again 

2 Various 
Artists 

Now That’s What I Call 
Music, Volume 1 

Backstreet Boys – As 
Long As You Love Me 

3 Various 
Artists 

Now That’s What I Call 
Music, Volume 1 

Fastball – The Way 

Unknowns on Import 
In the event that some of your imported music files show up as “Unknown” 
after being imported from a PC to the Fireball, this indicates either missing tag 
information or an unsupported tagging format or tag version. You will need to 
manually edit this information through the Fireball itself or delete the 
previously imported music through Options>Music Info>Delete Music and 
verify the process in which you have tagged your music files and re-import. 
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Windows Media Player - Tagging 

Step 1 
In order to properly edit your digital music files using Windows Media Player, 
you must first import these files into Windows Media Player. To import your 
music files, select File>Add to Library and choose one of the provided 
methods of importing your files. 

 
 

Step 2 
Once your music files have been imported, you may now edit the metadata 
associated with each file. You may either select a single file or multiple files to 
edit at one particular time.  The only time when you may need to select 
multiple files at a time is when the artist and album titles are inconsistent 
between multiple tracks of the same album. . It may also be beneficial to 
select multiple files when selecting the genre for an album. After selecting the 
desired files, right click and select “Advanced Tag Editor”. 
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Step 3 
From within the advanced tag editor you will now be able to associate the 
desired metadata with each of your music files. This information should 
include Artist, Album, Track #, Track Name, Genre and Cover Art (optional) in 
order for the Fireball to properly display this information once your music files 
have been imported. 
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Apple iTunes - Tagging 

Step 1 
Before importing any of your music files into Apple iTunes there are a couple 
preferences you will need to change/verify in order for your music to be 
imported in the proper format. In order to change/verify these settings select 
Edit>Preferences from the menu bar.  
 

 
 
You will then need to uncheck “Copy files to iTunes Music folder when adding 
to library” from the General tab and change “Import Using” from the Importing 
tab to MP3 Encoder. 
 

    
 

Step 2 
Now that you have properly setup your iTunes preferences, you will now need 
to import your files for editing. To import your music files, select File>Add 
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Folder to Library and choose the location from which you have stored your 
music files. 
 

Step 3 
Once iTunes has finished importing your music files you may now begin 
editing the associated metadata. You may either select a single file or multiple 
files to edit at one particular time.  The only time when you may need to select 
multiple files at a time is when the artist and album titles are inconsistent 
between multiple tracks of the same album. It may also be beneficial to select 
multiple files when selecting the genre for an album. After selecting the 
desired files, right click and select “Get Info”. 
 

 
 

Step 4 
From within the tag editor you will now be able to associate the desired 
metadata with each of your music files. This information should include Artist, 
Album, Track #, Track Name, Genre and Cover Art (optional) in order for the 
Fireball to properly display this information once your music files have been 
imported. 
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Step 5 
Once you have associated all desired metadata with your music files you will 
now need to convert the tag including this metadata to a Fireball compatible 
format. In order to do so, select all tracks which will be imported to the Fireball, 
right click and select “Convert ID3 Tags”. 
 

 
You will then Select “ID3 tag version” and v2.3. 
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Note:  If you experience problems in transferring multiple tracks of the same 
title to the Fireball that have been edited using iTunes, try removing the 
second field of the track metadata when right clicking on a track(s) and 
selecting Get Music Info within the Info tab. 
 

 
 
 
 
 

MP3 Tag v2.35 - Tagging 

Step 1 
In order to properly edit your digital music files using MP3 Tag, you must first 
import these files into MP3 Tag. To import your music files, select 
File>Change Directory and choose the desired location to import your files 
from. 
 



FireBall – Supported Digital Music Formats & Tagging Requirements 
2/18/2010 

 

6640 Intech Blvd.   Indianapolis, IN 46278   317.616.6789 phone   317.616.6790 fax   www.escient.com 
 

 

 
 
 

Step 2 
Once your music files have been imported you may now begin associating 
the required metadata with each file. This information should include Artist, 
Album, Track #, Track Name, and Genre in order for the Fireball to properly 
display this information once your music files have been imported. You may 
either select a single file or multiple files to edit at one particular time.  The 
only time when you may need to select multiple files at a time is when the 
artist and album titles are inconsistent between multiple tracks of the same 
album. . It may also be beneficial to select multiple files when selecting the 
genre for an album.  
 
Each time you highlight either a single or multiple tracks within the right pane 
you will be able to edit the associated metadata in the left pane. After each 
change to the metadata associated with your file(s) you will need to click the 
Save icon at the top left of the application in order to commit your changes.  
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